Incident on audio storage services for managedradio. and library.
Resolved
Sep 27 at 07:45am CEST
The upstream issue in the Switzerland North Azure region has been resolved, and storage services are fully operational again. All affected managedradio. staging and test deployments have returned to their normal state.
Thank you for your patience throughout this incident.
Affected services
Updated
Sep 27 at 04:28am CEST
Microsoft Azure has confirmed a multi-service impact in the Switzerland North region starting at 23:54 UTC on 26.09.2025. The issue is linked to a recent networking change, and a hotfix is being prepared.
At this time, the impact for managedradio. is currently limited to staging and test deployments only. No production customers are affected, and no action is required on your side.
We continue to monitor closely and will provide further updates as Azure progresses with their mitigation.
Affected services
Updated
Sep 27 at 03:55am CEST
The issue is currently limited to staging and test deployments and does not impact any production customers. We are waiting on the underlying storage issue in Switzerland North to be resolved.
Our engineering team continues to monitor service health closely. No customer action is required at this time. We will provide another update as progress is made or if the scope of impact changes.
Affected services
Updated
Sep 27 at 03:38am CEST
We have identified that the root cause of this incident is a failing storage service in the Switzerland North Azure region. This issue is currently affecting a limited number of managedradio. accounts.
Our engineering team is actively working on a solution to restore full functionality as quickly as possible. We will provide another update as soon as more information becomes available.
Thank you for your patience.
Affected services
Created
Sep 27 at 03:09am CEST
We’re investigating an issue with our managedradio. and library. audio storage that is impacting some users. We have identified that an underlying storage issue with Azure in the Switzerland North region is causing managedradio. channels and library. audio storage to fail.
We’re working to resolve the problem as quickly as we can. We’ll share another update shortly.
Affected services